Introduction

This help document is intended to provide in-depth information and reference material specific to your digitizer product.

For information on getting started with your digitizer, please refer to the Startup Guide which was delivered with your product or may be downloaded from the Keysight Technologies website.

Contents:

Notices & General Information

Get More Assistance

TIP: Help Search Techniques

Related Documentation

Full Product Family Listing & Cross-reference tables

Introduction

Front Panel Features

Channel Input

Data Acquisition

Trigger

External Clock and Reference

Calibration

Trigger Output

Multi-Purpose Inputs and Outputs

Signal Processing (Firmware Options)

Averager (AVG)

Electrical, Environmental & Physical Specifications

Programming Information

Warning when migrating from MD2 1.x to MD2 2.x

Initial Configuration

How To ...

ApplySetup

MATLAB support and known limitations

Utilities

Firmware Upgrade Utility

Option Upgrade Utility

FAQs

© Keysight Technologies 2016

Part No: U5310-90005

April, 2016


Notices

© Keysight Technologies, 2016

No part of this manual may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Keysight Technologies, Inc. as governed by United States and international copyright laws.

Manual Part Number

U5310-90005

Support

To contact Keysight for sales and technical support, refer to the “support” links on the following Keysight web resources:

www.keysight.com/find/digitizers - Home page for the entire range of Keysight modular digitizer products.

www.keysight.com/find/assist - Worldwide contact information for repair and service.

www.keysight.com/find/tips - Information on preventing damage to your Keysight equipment.

Regulatory Compliance

This product has been designed and tested in accordance with accepted industry standards, and has been supplied in a safe condition. To review the Declaration of Conformity, go to http://www.keysight.com/go/conformity .

Warranty

The material contained in this document is provided “as is,” and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Keysight disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Keysight shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information contained herein. Should Keysight and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.

Keysight Technologies does not warrant third-party system-level (combination of chassis, controllers, modules, etc.) performance, safety, or regulatory compliance, unless specifically stated.

Technology Licenses

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

U.S. Government Rights

The Software is “commercial computer software,” as defined by Federal Acquisition Regulation (“FAR”) 2.101. Pursuant to FAR 12.212 and 27.405-3 and Department of Defense FAR Supplement (“DFARS”) 227.7202, the U.S. government acquires commercial computer software under the same terms by which the software is customarily provided to the public. Accordingly, Keysight provides the Software to U.S. government customers under its standard commercial license, which is embodied in its End User License Agreement (EULA), a copy of which can be found at http://www.keysight.com/find/sweula. The license set forth in the EULA represents the exclusive authority by which the U.S. government may use, modify, distribute, or disclose the Software. The EULA and the license set forth therein, does not require or permit, among other things, that Keysight: (1) Furnish technical information related to commercial computer software or commercial computer software documentation that is not customarily provided to the public; or (2) Relinquish to, or otherwise provide, the government rights in excess of these rights customarily provided to the public to use, modify, reproduce, release, perform, display, or disclose commercial computer software or commercial computer software documentation. No additional government requirements beyond those set forth in the EULA shall apply, except to the extent that those terms, rights, or licenses are explicitly required from all providers of commercial computer software pursuant to the FAR and the DFARS and are set forth specifically in writing elsewhere in the EULA. Keysight shall be under no obligation to update, revise or otherwise modify the Software. With respect to any technical data as defined by FAR 2.101, pursuant to FAR 12.211 and 27.404.2 and DFARS 227.7102, the U.S. government acquires no greater than Limited Rights as defined in FAR 27.401 or DFAR 227.7103-5 (c), as applicable in any technical data.

Conventions Used in this Document

The following conventions are used in this document:

A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.

A Caution notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met

This is a note, drawing the reader's attention to important information, caveats, etc.

'Italic' text denotes a reference to a quoted name or entity. e.g."Press the 'Run' button."

Bold Italic text is used to emphasize an important action point in the text. e.g. "Open the View menu and select the All option."

mono text is used for sections of code, programming examples and operating system commands. e.g. "Type the command >> Run -all"

Underlined Italic text denotes paths or file names. e.g. "The file is located in the folder, e.g...\Keysight\MD2\.."

Safety Notices

The following safety precautions should be observed before using this product and any associated instrumentation.

This product is intended for use by qualified personnel who recognize shock hazards and are familiar with the safety precautions required to avoid possible injury. Read and follow all installation, operation, and maintenance information carefully before using the product.

If this product is not used as specified, the protection provided by the equipment could be impaired. This product must be used in a normal condition (in which all means for protection are intact) only.

The types of product users are:

  • Responsible body is the individual or group responsible for the use and maintenance of equipment, for ensuring that the equipment is operated within its specifications and operating limits, and for ensuring operators are adequately trained.
  • Operators use the product for its intended function. They must be trained in electrical safety procedures and proper use of the instrument. They must be protected from electric shock and contact with hazardous live circuits.
  • Maintenance personnel perform routine procedures on the product to keep it operating properly (for example, setting the line voltage or replacing consumable materials). Maintenance procedures are described in the user documentation. The procedures explicitly state if the operator may perform them. Otherwise, they should be performed only by service personnel.
  • Service personnel are trained to work on live circuits, perform safe installations, and repair products. Only properly trained service personnel may perform installation and service procedures.

Operator is responsible to maintain safe operating conditions. To ensure safe operating conditions, modules should not be operated beyond the full temperature range specified in the Environmental and physical specification. Exceeding safe operating conditions can result in shorter lifespans, improper module performance and user safety issues. When the modules are in use and operation within the specified full temperature range is not maintained, module surface temperatures may exceed safe handling conditions which can cause discomfort or burns if touched. In the event of a module exceeding the full temperature range, always allow the module to cool before touching or removing modules from chassis.

Keysight products are designed for use with electrical signals that are rated Measurement Category I and Measurement Category II, as described in the International Electrotechnical Commission (IEC) Standard IEC 60664. Most measurement, control, and data I/O signals are Measurement Category I and must not be directly connected to mains voltage or to voltage sources with high transient over-voltages. Measurement Category II connections require protection for high transient over-voltages often associated with local AC mains connections. Assume all measurement, control, and data I/O connections are for connection to Category I sources unless otherwise marked or described in the user documentation.

Exercise extreme caution when a shock hazard is present. Lethal voltage may be present on cable connector jacks or test fixtures. The American National Standards Institute (ANSI) states that a shock hazard exists when voltage levels greater than 30V RMS, 42.4V peak, or 60VDC are present. A good safety practice is to expect that hazardous voltage is present in any unknown circuit before measuring.

Operators of this product must be protected from electric shock at all times. The responsible body must ensure that operators are prevented access and/or insulated from every connection point. In some cases, connections must be exposed to potential human contact. Product operators in these circumstances must be trained to protect themselves from the risk of electric shock. If the circuit is capable of operating at or above 1000V, no conductive part of the circuit may be exposed.

Do not connect switching cards directly to unlimited power circuits. They are intended to be used with impedance-limited sources. NEVER connect switching cards directly to AC mains. When connecting sources to switching cards, install protective devices to limit fault current and voltage to the card.

Before operating an instrument, ensure that the line cord is connected to a properly-grounded power receptacle. Inspect the connecting cables, test leads, and jumpers for possible wear, cracks, or breaks before each use.

When installing equipment where access to the main power cord is restricted, such as rack mounting, a separate main input power disconnect device must be provided in close proximity to the equipment and within easy reach of the operator.

For maximum safety, do not touch the product, test cables, or any other instruments while power is applied to the circuit under test. ALWAYS remove power from the entire test system and discharge any capacitors before: connecting or disconnecting cables or jumpers, installing or removing switching cards, or making internal changes, such as installing or removing jumpers.

Do not touch any object that could provide a current path to the common side of the circuit under test or power line (earth) ground. Always make measurements with dry hands while standing on a dry, insulated surface capable of withstanding the voltage being measured.

The instrument and accessories must be used in accordance with its specifications and operating instructions, or the safety of the equipment may be impaired.

Do not exceed the maximum signal levels of the instruments and accessories, as defined in the specifications and operating information, and as shown on the instrument or test fixture panels, or switching card.

When fuses are used in a product, replace with the same type and rating for continued protection against fire hazard.

Chassis connections must only be used as shield connections for measuring circuits, NOT as safety earth ground connections.

If you are using a test fixture, keep the lid closed while power is applied to the device under test. Safe operation requires the use of a lid interlock.

Instrumentation and accessories shall not be connected to humans.

Before performing any maintenance, disconnect the line cord and all test cables.

To maintain protection from electric shock and fire, replacement components in mains circuits – including the power transformer, test leads, and input jacks – must be purchased from Keysight. Standard fuses with applicable national safety approvals may be used if the rating and type are the same. Other components that are not safety-related may be purchased from other suppliers as long as they are equivalent to the original component (note that selected parts should be purchased only through Keysight to maintain accuracy and functionality of the product). If you are unsure about the applicability of a replacement component, call an Keysight office for information.

No operator serviceable parts inside. Refer servicing to qualified personnel. To prevent electrical shock do not remove covers. For continued protection against fire hazard, replace fuse with same type and rating.

PRODUCT MARKINGS:

The CE mark is a registered trademark of the European Community.

Australian Communication and Media Authority mark to indicate regulatory compliance as a registered supplier.

This symbol indicates product compliance with the Canadian Interference-Causing Equipment Standard (ICES-001). It also identifies the product is an Industrial Scientific and Medical Group 1 Class A product (CISPR 11, Clause 4).

South Korean Class A EMC Declaration. this equipment is Class A suitable for professional use and is for use in electromagnetic environments outside of the home.

A 급 기기 ( 업무용 방송통신기자재 ) 이 기기는 업무용 (A 급 ) 전자파적합기기로서 판 매자 또는 사용자는 이 점을 주 의하시기 바라 며 , 가정외의 지역에서 사용하는 것을 목적으 로 합니다 .

This product complies with the WEEE Directive marketing requirement. The affixed product label (above) indicates that you must not discard this electrical/electronic product in domestic household waste. Product Category: With reference to the equipment types in the WEEE directive Annex 1, this product is classified as “Monitoring and Control instrumentation” product. Do not dispose in domestic household waste. To return unwanted products, contact your local Keysight office, or for more information see http://about.keysight.com/en/companyinfo/environment/takeback.shtml.

This symbol on an instrument means caution, risk of danger. You should refer to the operating instructions located in the user documentation in all cases where the symbol is marked on the instrument.

This symbol indicates the time period during which no hazardous or toxic substance elements are expected to leak or deteriorate during normal use. Forty years is the expected useful life of the product.

ESD Sensitive Device

This symbol indicates the instrument is sensitive to electrostatic discharge (ESD). ESD can damage the highly sensitive components in your instrument. ESD damage is most likely to occur as the module is being installed or when cables are connected or disconnected. Protect the circuits from ESD damage by wearing a grounding strap that provides a high resistance path to ground. Alternatively, ground yourself to discharge any built-up static charge by touching the outer shell of any grounded instrument chassis before touching the port connectors.

This symbol denotes a hot surface. The side cover of the module will be hot after use and should be allowed to cool for several minutes.

Cleaning Precautions:

To prevent electrical shock, disconnect the Keysight Technologies instrument from mains before cleaning. Use a dry cloth or one slightly dampened with water to clean the external case parts. Do not attempt to clean internally. To clean the connectors, use alcohol in a well-ventilated area. Allow all residual alcohol moisture to evaporate, and the fumes to dissipate prior to energizing the instrument.

Definitions for specifications

Specifications describe the warranted performance of calibrated instruments that have been stored for a minimum of 2 hours within the operating temperature range of 0 to 45 °C, unless otherwise stated, and after a 45 minute warm-up period. Data represented in this document are not specifications unless otherwise noted.

Characteristics describe product performance that is useful in the application of the product, but that is not covered by the product warranty. Characteristics are often referred to as Typical or Nominal values.

  • Typical describes characteristic performance, which 80% of instruments will meet when operated over a 20 to 30 °C temperature range. Typical performance is not warranted.
  • Nominal describes representative performance that is useful in the application of the product when operated over a 20 to 30 °C temperature range. Nominal performance is not warranted.


Get More Assistance

  • Related Documentation
  • Go to U5310A Website: www.keysight.com/find/U5310A
  • Go to High Speed Digitizer Product Website
  • Go to Support Website


View Product Information on Keysight.com

To go to the Product Website, click on the following link:

http://www.keysight.com/find/digitizers


View Support Information on Keysight.com

To go to the Support Website, click the following link:

http://www.keysight.com/find/assist


TIP: Help Search Tricks

In the help system, a basic search of topics consists of the word or phrase that you want to find. You can, however, improve your search results by using wildcard expressions, nested expressions, Boolean operators, and searching similar word matches, previous results, and topic titles only.

Performing a Basic Full-Text Search

  1. In the navigation pane, click the Search tab and then type the word or phrase that you want to find. Use the right-arrow button to add Boolean operators to your search.
  • Click List Topics.Your search will return the first 500 hits. If you want to sort the topic list, click Title, Location, or Rank.
  • Highlight the topic that you want, and then click Display You can also display any topic by double-clicking it.

Refining a Your Search

You can refine a basic search by using wildcard expressions, nested expressions, and Boolean operators. You can also search only on the previous results list, request similar word matches, or search only the titles of topics in the table of contents.

  • To refine a search to include just the last group of topics you searched, select the Search previous results check box.
  • To match similar spellings in a full-text search, select the Match similar words check box.

When Match similar words is selected, the viewer matches minor grammatical variations of the word or phrase you entered, as well as the word or phrase itself. For example, if you entered "test" and selected this box, the Library viewer would find "test", "tests", and "testing". This option is independent of other options or syntax. If you do a titles-only search, variations in titles will be matched. If you use quotes (or any other query operator) any variation of the word can appear; for example, "installed module" will also match "installing module".

  • To search for words in document titles only, select the Search titles only check box.

Search Syntax

The basic rules for formulating queries are as follows:

  • Searches are not case-sensitive, so you can type your search in uppercase or lowercase characters.
  • You can search for any combination of letters (a–z) and numbers (0–9). You cannot search for single letters (a, b, c, etc.) and the following reserved words: an, and, as, at, be, but, by, do, for, from, have, he, in, it, not, of, on, or, she, that, the, there, they, this, to, we, which, with, you.
  • Punctuation marks such as the period (.), colon (:), semicolon (;), comma (,), and hyphen (-) are ignored during a search.
  • Group the elements of your search using "double quotes" or (parentheses). You cannot search for quotation marks.
If you are searching for a filename with an extension, you should group the entire string in double quotes ("filename.ext"). Otherwise, the search will treat the period as an OR operator.

Words, Phrases, and Wildcards

You can search for words or phrases and use wildcard expressions. The table below describes the results of these different kinds of searches.

Search for | Example | Results
Single word | Calibrate | Topics that contain the word "calibrate." (You will also find its grammatical variations, such as "calibration" and"calibrated".)
Phrase | "saved configuration" -or- 'saved configuration' | Topics that contain the literal phrase "saved configuration" and all its grammatical variations. Without the quotation marks, the query is equivalent to specifying a saved AND configuration, which will find topics containing both of the individual words, instead of the phrase.
Wildcard expressions | Meas* | Topics that contain the terms "Meas," "measure," "measurement," and so on. The asterisk cannot be the only character in the words.
 | 89?00 | Topics that contain the terms "89500," "89600," "89700," and so on. The question mark cannot be the only character in the term.
 | *936* | Topics that contain the terms "936." "45936,""M9360A," "93600" and so on.
 | *93 | Topics that contain the terms "293," "393," "x93," "ABCD393," "8093," and so on.

Operators: AND, OR, NOT, and NEAR

The AND, OR, NOT, and NEAR operators allow you to refine your search. The following table shows how to use each of these operators.

Search for | Example | Results
Both terms in the same topic | performance AND verification -or- performance & verification | Topics containing both the words "performance" and "verification."
Either term in a topic | front OR panel -or- front | panel | Topics containing either the word "front" or the word "panel."
The first term without the second term | system NOT requirements -or_ system ! requirements | Topics containing the word "system," but not the word "requirements."
Both terms in the same topic, close together | install NEAR hardware | Topics containing the word "install" within eight words of the word "hardware."

Rules for Nested Expressions

The basic rules for searching topics using nested expressions are as follows:

  • You can use parentheses to nest expressions within a query. The expressions in parentheses are evaluated before the rest of the query.
  • If a query does not contain a nested expression, it is evaluateds from left to right. For example, "Instrument NOT system OR calibration" finds topics containing the term "instrument" without the term "system", or topics containing the term "instrument" and not "calibration". (On the other hand, "instrument NOT (system OR calibration)" finds topics containing the term "instrument" without either of the terms "system" or "calibration".)
  • Nesting allows you to create more complex search expressions. For example, "instrument AND ((system OR calibration) NEAR performance)" finds topics containing the term "instrument" along with the terms "system" and "performance" close together, or containing "instrument" along with the terms "calibration" and "performance" close together.
  • You cannot nest expressions more than five levels deep.


Related Documentation

Documentation Access Map

All documentation relating to your Keysight Technologies digitizer may be found either from the DVDs supplied with your product, or from the Keysight

Documentation

If you have run the Keysight software installer for your product on your PC, the related product documentation has been installed to your hard drive. Otherwise these documents are available for download from the Keysight Technologies website.

Document | Description
Startup Guide | Includes procedures to help you to unpack, inspect, install (software and hardware), perform instrument connections, verify operation, and troubleshoot your product.
User Manual | Provides in-depth information and reference material specific to your digitizer product
Data Sheet | In addition to a detailed product introduction, the data sheet supplies full product specifications.
Soft Front Panel (help system) | Provides information on the use of the Soft Front Panel.
LabVIEW Driver reference (help system) | Provides detailed documentation of the LabVIEW G driver API functions.
IVI Driver reference (help system) | Provides detailed documentation of the IVI-COM and IVI-C driver API functions, as well as information to help you get started with using the IVI drivers in your application development environment.


Full Product Family Listing & Cross-reference tables

This help file has been organized to allow easy access by arranging the product lines under their form factors listed below:

PCI Express Digitizers

The products in the industry standard PCI Express format benefit from the very high data transfer rates of the PCIe interface, and occupying a single slot in a host PC. They also feature programmable on-board processing capabilities.

Keysight Model Number | Model Name
U1084A | 8-bit PCIe High-Speed PCIe Digitizer with on-board signal processing
U5303A | 12-bit PCIe High-speed Digitizer with on-board signal processing
U5309A | 8-bit PCIe High-Speed Digitizer with on-board signal processing
U5310A | 10-bit PCIe High-Speed Digitizer with on-board signal processing

Note: That the U1084A product utilizes PCIe Gen 1.1 and a x4 slot, whereas the U53xx series support PCIe Gen 2.0 and a x8 slot.

PXI Express High-Speed Digitizers

This product line is composed of Keysight PXI Express new generation of high-speed digitizers.

These are PXI Express compliant, using either a PXIe or PXIe Hybrid slot. Designed to benefit from fast data interfaces, the products can be integrated with other test and automation modules in PXIe and Hybrid chassis slots. The PXI format offers high performance in a small, rugged package. It is an ideal deployment platform for many automated test systems

Keysight Model Number | Model Name
M9202A | PXI Express 12-bit Wideband IF Digitizer
U5203A | PXI Express 12-bit High-Speed Digitizer
M9203A | PXI Express 12-bit High-Speed Digitizer/ Wideband Digital Receiver
AXIe Digitizers

This product line is composed of Keysight Technologies new generation of AXIe Digitizers.

The AXIe format offers high performance in a highly scalable package, offering at least twice the channel density of currently available comparable solutions. Making it ideally suited to large scale experiments in applied physics, such as particle physics, nuclear fusion, hydrodynamics or microwave radio astronomy.

Keysight Model Number | Model Name
M9703A | AXIe 12-bit, 8 channels Wideband Digitizer
M9703B | AXIe 12-bit, 8 channels Wideband Digitizer
M9709A | AXIe 8-bit, 32 channels Wideband Digitizer


Keysight U5310A PCIe Digitizer Introduction

Overview

The U5310A is a true two channel PCIe, DC coupled 10-bit digitizer providing sample rates up to 10 GS/s with 2.5 GHz bandwidth for use by OEM Closed Original Equipment Manufacturer’s in a variety of advanced imaging and processing systems, also allowing real-time data processing capability.

The U5310A PCIe digitizer is particularly suited for embedded OEM applications requiring digitizer sampling at wide bandwidth and moderate dynamic range. Overall performance enables customer's final products to more precisely measure time of flight for a variety of end system applications.

Product description

The U5310A ADC Closed Analog to Digital Converter card occupies a single full-length PCIe slot of the host PC. Featuring sample rates of up to 5 GS/s per channel, up to 10 GS/s in interleaved mode, along with an analog bandwidth of up to 2.5 GHz and DDR3 acquisition memory options up to 4 GB, the U5310A includes a Xilinx Virtex-6 FPGA Closed Field Programmable Gate Array for real-time processing.

The standard digitizer firmware included allows signal acquisition to the on-board memory and subsequent transfer to the host PC via its fast PCI Express 2.0 eight lanes connection.

At the heart of the U5310A is a data processing unit (DPU Closed Digital Processing Unit) based on the powerful Xilinx Virtex-6 FPGA. This DPU is responsible for controlling the module functionality, data flow and real-time signal processing. This powerful feature allows data reduction and storage to be carried out at the digitizer level, minimizing transfer volumes and speeding-up analysis.

Figure 1 - U5310A block diagram

Most of the technical specifications concerning your particular digitizer are covered in this manual, however for the complete specifications please refer to the product's datasheet from the Keysight Technologies web site www.keysight.com/find/U5310A. These data sheets are available in pdf format and are best viewed using Adobe Acrobat software. If you have trouble accessing our web site, or viewing the data sheets, please contact your nearest sales office.


U5310A Front Panel Features

Please note that analog Input IN 1 and IN 2 have a maximum voltage limitation of ±1.5 Vmax while using the default 1V full scale range (±0.5 Vmax if using 0.25V FSR Closed Full Scale Range:- The span of the voltage input of the Digitizer (negative to positive) including the configured offset voltages.).

Front Panel Connectors

Connector | Type | Description
TRG IN | MMCX female | External trigger input, 50 Ω DC terminated, ±5 V range.
IN 1, 2 SMA female

Analog signal inputs, DC-coupled and 50 Ω terminated.

The input full scale ranges are selectable:

Range | Maximum Input
0.25 V | ± 500 mVpk
1 V | ±1.5 Vpk
JTAG | Micro USB | Provides connection to the DPU Closed Digital Processing Unit for use with the U5340A FPGA Closed Field Programmable Gate Array Development Kit.(Not supported)
TRG OUT | MMCX female | Trigger Out signal. User selectable from several functions.
I/O 1, 2, 3 | MMCX female | User configurable Input / Output signal. 3.3 V CMOS and TTL compatible.
CLK IN | MMCX female | External clock input. AC coupled and 50 Ω terminated, signal level: +5 to +15 dBm. For supported frequencies, please refer to the U5310A Datasheet.
REF IN | MMCX female | External reference clock input, AC coupled and 50 Ω terminated. It can accept a 100 MHz signal from -3 to +3 dBm.

Front Panel LEDs

Indicator | Purpose | Color | State | Meaning
DPU | DPU status |  | Off | DPU is not configured
 |  |  | Green, blinking | Module initialization in progress
 |  |  | Green | Module OK (firmware not yet loaded)
 |  |  | White | DPU firmware loaded (ready)
STATUS | Module status |  | White, blinking | Firmware initialization in progress
 |  |  | Green, blinking | Module initialization in progress
 |  |  | Yellow, blinking | Warning
 |  |  | Red, blinking | Error
 |  |  | Green | OK (ready)

If warning or error status is observed, please try the following steps:

  • Power-cycle the chassis (If using a PCIe interface to external PC, observe the power sequence requirements)
  • If the error persists please contact Keysight technical support http://www.keysight.com/find/assist.

Adding custom stickers on digitizers

If user want to add a custom sticker on the module, there is a dedicated area on the top shield of the digitizer (see picture below).

If applying custom stickers in other areas, the sticker may peel away due to local temperature increase.

In case of application of a custom sticker on the main shield and non-dedicated area, Keysight does not warranty cooling performance.

Top shield of U5310A digitizer.


Channel Input Specifications

This section provides information and specifications regarding the input characteristics of the digitizer.

The U5310A provides two 5 GS/s 10-bit DC-coupled channels. The two channels may be combined to form an interleaved channel at 10 GS/s (U5310A-INT option).

Channel Input

The U5310A has the following front end capabilities:

Coupling / Impedance | Full Scale Ranges (FSR Closed Full Scale Range:- The span of the voltage input of the Digitizer (negative to positive) including the configured offset voltages.) | Maximum operating voltage | Input voltage offset
DC / 50 Ω | 250 mV | ±0.5 V | ± FSR
 | 1 V | ±1.5 V | ± FSR

Impedance & Coupling

The input channel termination is 50 Ω. The input coupling is DC.

Input Protection

The input amplifiers are designed to accept signals below the absolute maximum level shown in the table.

Mezzanine Front-end

The front-end electronics are all mounted on a removable mezzanine card. In the event of accidental damage or as components fatigue over time (e.g. relays in high duty cycle automated testing applications), the mezzanine card allows for fast and efficient replacement.

Bandwidth and Rise Time

The bandwidth specification indicates the frequency at which an input signal will be attenuated by 3 dB (approximately 30% loss of amplitude).

Options |  |  | Input Frequency Range |  |
 |  |  | 1 V FSR | 0.5 V FSR | Enabling BW Limiter
-F25 | -SR4 | — | DC to 2.5 GHz (typical) |  | DC to 2 GHzSpecified with default mode "Equalization Off". 1 (typical)
 |  | -INT

The bandwidth also has an impact on the minimum rise and fall times that can be passed through the front-end electronics. A pulse with a very sharp edge will be observed to have a minimum rise timeTmin determined by the front-end electronics. In general a pulse with a given 10-90% rise time T10-90real will be observed with a lower value given by:

T10-90=T10-90real2+Tmin2

where Tmin(ns)≈0.35/BW(GHz).

Using Bandwidth Limiter

U5310A digitizers offer a 2 GHz bandwidth limiter1 capability

Also see Programing section >How to enable or bypass the filter?.

When using the bandwidth limiter, it is recommended to use the default equalization mode (Equalization off).

Vertical Resolution

The U5310A PCIe High-Speed Digitizer uses a 10-bit ADC Closed Analog to Digital Converter giving 1024 levels at each input full scale range. The typical effective number of bits (ENOB Closed Effective Number Of Bits - expresses the quality of the ADC quantification.) is 7.2 at 100 MHz and 7 at 1.9 GHz (measured at 5 GS/s for a -1 dBFS Closed Decibels relative to full scale - the power ratio between the theoretical power of a full scale sinusoid and the highest spurious peak. input signal).


Data Acquisition

The sections below summarize the data acquisition characteristics.

Sampling Rate

The U5310A Digitizer contains an analog-to-digital conversion (ADC Closed Analog to Digital Converter) system that can sample waveforms, in a real time sampling mode, at rates shown in the table below. The maximum sampling rate shown above is achieved by combining the two channels.

Model | Option | Max. Sampling Rate | Available Channels | Resolution | Acquisition Modes
U5310A | -SR4 | 5 GS/s | 2 | 10 bits | Single or multi-record (up to 131'072 records)
 | -SR4 and INT | 10 GS /s | 1

The External Clock can be used to vary the sampling rate of the digitizer, see External Clock and Reference.

Acquisition Memory

Data from the ADC is stored in on-board acquisition memory. The amount of memory in use for acquisition can be programmed and is selectable from 1 point to the full amount of acquisition memory available.

Model | Option | Acquisition Memory | Samples/channel
U5310A | -M02 | 256 MB | 100 MS/ch
 | -M10 | 1 GB | 400 MS/ch
 | -M40 | 4 GB | 1.6 GS/ch

For technical reasons, a certain acquisition memory “overhead” is required for each waveform, reducing the available memory by a small amount.

After acquisition, the raw 10-bit data is subjected to post-calibration processing, which compensates for gain and offset errors in the internal ADCs, The result of this post-processing is then stored and read-out as a 16-bit value. For this reason the returned data will not always be divisible by 16 as may be expected.

Single and Multi-Record Acquisition Modes

Digitizers acquire waveforms in association with triggers. Each waveform is made of a series of measured voltage values (sample points) that are made by the ADC at a uniform clock rate.

To maximize sampling rates and utilize memory as efficiently as possible the digitizers include both Single and Sequential storage modes. For both of these modes the data of all of the active channels is acquired synchronously; all of the ADC's are acquiring data at the same time, to within a small fraction of the maximum sampling rate.

The Single Acquisition mode is the normal operation of most digitizer products. In this mode an acquisition consists of a waveform recorded with a single trigger. The user selects the sampling rate and acquisition memory size and sets the number of records to 1 (default value). For details about the trigger sources, see Trigger.

The digitizers also feature a multi-record acquisition mode. This mode allows the capture and storage of consecutive “single” waveforms. Multi-record acquisition mode is useful as it can optimize the digitizer's sampling rate and memory requirements for applications where only portions of the signal being analyzed are important. The mode is extremely useful in almost all impulse-response type applications (RADAR, SONAR, LIDAR, Time-of-Flight, Ultrasonics, Medical and Biomedical Research, etc.).

In multi-record acquisition mode the acquisition memory is divided into a pre-selected number of records. Waveforms are stored in successive memory records as they arrive. Each waveform requires its own individual trigger.

Multi-record acquisition enables successive events, which can occur within a very short time, to be captured and stored without loss. A crucial feature of multi-record acquisition mode is that it has a very fast trigger rearm time. A fast trigger rearm helps produce very low “dead time” between the records of a multi-record acquisition. The “dead time” is the period after the end of an event when the card cannot digitize data for a new trigger event.

Trigger Time Interpolator

The digitizer also measures and stores the arrival time of each trigger using the information from the on board Trigger Time Interpolator (TTI Closed Trigger Time Interpolator:- A function that accurately measures the time from the trigger point to the first sample point. The TTI permits accurate positioning of the trigger signal with respect to the internal clock (sampling time).). This information is essential for determining the precise relation between the trigger and the digitized samples of the signal. The TTI resolution determines the resolution of the trigger time stamps.

Timebase Range

The timebase range defines the time period over which data is being acquired. For example, the U5310A-M02-SR4 has a standard acquisition memory of 100 MS/ch and maximum sampling rate of 5 GS/s (non-interleaved). Therefore, at the maximum sampling rate, the digitizer can record a signal over a time window of up to .

Combining channels (Interleaving -INT option)

The U5310A digitizer offers the possibility of combining the converters (and their memories) from two channels to analyze a single input channel. With this feature the maximum sampling rate and the maximum amount of acquisition memory can be doubled if all of the input channels are not of immediate interest.

Equalization

When performing analog to digital conversion at very high sampling rate, using an equalization improves the frequency response and compensate for signal distortion.

By default, the digital frequency equalization in disabled.

Two equalization modes can be selected:

  • The smooth roll off minimizes the overshoot and ringing.
  • The sharp roll off optimizes the frequency response flatness.

It is also possible to implement a user custom equalization, depending on your application. To proceed, please contact factory: digitizers@keysight.com. By default, Custom Equalization is equivalent to Equalization Off.

The figures below show the characteristics of each equalization mode.

The equalization option is supported for both digitizer (-DGT) and averager (-AVG) modes.

Frequency responses depending on the equalization modes

Figure 2 - Frequency response (typical) measured at 1 V FSR Closed Full Scale Range:- The span of the voltage input of the Digitizer (negative to positive) including the configured offset voltages., and 10 GS/s, using default equalization mode: off.

Figure 3 - Frequency response (typical) measured at 1 V FSR, and 10 GS/s, using equalization mode: Smooth Roll Off.

Figure 4 - Frequency response (typical) measured at 1 V FSR, and 10 GS/s, using equalization mode: Sharp Roll Off.

Pulse responses

The diagrams below show an example of pulse response (nominal) (pulse: 0.7 V amplitude, 6.25 ns width).

Figure 5 - Pulse response (Nominal) measured at 1 V FSR, and 10 GS/s, using default equalization mode: Off.

Figure 6 - Pulse response (Nominal) measured at 1 V FSR, and 10 GS/s, using default equalization mode: Smooth Roll Off.

Figure 7 - Pulse response (Nominal) measured at 1 V FSR, and 10 GS/s, using default equalization mode: Sharp Roll Off.

Equalization and bandwidth limiter

The bandwidth limiter (BWL) capability is independently programmable from the Equalization mode.

However if you are using the 2 GHz bandwidth limiter, it is recommended to use the default equalization mode (i.e. Equalization off).

As illustrated below, this mode exhibit a very good performance in term of frequency flatness.

Figure 8 - Pulse response (Nominal) measured at 1 V FSR, and 10 GS/s, using the bandwidth limiter and equalization mode: Off.

Driver property / attribute

The equalization mode can be selected as detailed below:

Driver | Attribute / Property | Available Instance Value | Description
IVI-C | AGMD2_ATTR_CALIBRATION_EQUALIZATION | AGMD2_VAL_CALIBRATION_EQUALIZATION_OFF AGMD2_VAL_CALIBRATION_EQUALIZATION_CUSTOM AGMD2_VAL_CALIBRATION_EQUALIZATION_SMOOTH_ROLL_OFF AGMD2_VAL_CALIBRATION_EQUALIZATION_SHARP_ROLL_OFF | Equalization off Custom equalization Smooth Roll-off equalization Sharp Roll-off equalization
IVI-COM | IAgMD2Calibration2.Equalization | AgMD2CalibrationEqualizationOff AgMD2CalibrationEqualizationCustom AgMD2CalibrationEqualizationSmoothRollOff AgMD2CalibrationEqualizationSharpRollOff | Equalization off Custom equalization Smooth Roll-off equalization Sharp Roll-off equalization

Managing ADC signal potential overrange

An overrange condition occurs when the signal amplitude is larger than the digitizer full scale range.

It results in clipping the ADC sample value to its maximum.

Shifting the input signal with the channel offset control or simply acquiring signal with amplitude close to the selected FSR can results in an overrange condition.

The digitizer is able to detect and report if such an event occurs during the acquisition. Due to maximum input voltage requirements and to the resulting clipped sample data, the default driver behavior is to return an error in such a condition.

Note, that the acquired data are still available for read (see example below).

It is also possible to disable the overrange detection.

Due to the internal ADC frequency response superior to 0 dB for high-frequencies (see above the Bode plot without equalization), there is a risk of signal overrange at the ADC output, even if the input signal is included within the digitizer FSR.

The equalization mode has not impact on any overrange condition.

Driver property / attribute and usage example

By default, the ErrorOnOverrangeEnabled property is set to true (default). In that case, all Fetch and Read methods returns an error if one or more samples were in overranged.

To read/fetch data despite the overrange, the property must be set to false, and the read/fetch methods must be called again (See example below).

If the ErrorOnOverrangeEnabled property is set to false, and one or more samples were in overranged, the driver doesn't return any error.

Driver | Attribute / Property (Boolean) | Description
IVI-C | AGMD2_ATTR_ERROR_ON_OVERRANGE_ENABLED | When set to true, all Fetch and Read methods will return an error if the ADC was in overrange (i.e. some samples are outside of the numeric range of the ADC output). Default is true .
IVI-COM | IAgMD2Acquisition4.ErrorOnOverrangeEnabled

Example (pseudo-instructions)

//Acquired data reading procedure

Fetch();

If (error) {

ErrorOnOverrangeEnabled=false; // allow fetch of overrange data

Fetch();

ErrorOnOverrangeEnabled=true; // reset

}

Binary Decimation

A programmable binary decimation may be used to lower the sample rate by a ratio of 2, 4 or 8.

To enable decimation, user should set the sampling rate to required decimated sampling rate.

For instance, without interleaving:

Decimation Ratio | Resulting sampling rate
2 | 2.5 GHz
4 | 1.25 GHz
8 | 625 MHz


Trigger

The trigger settings applied to the digitizer are used to determine at which time the device will stop acquiring data. The various trigger settings are outlined below.

Trigger Source

The trigger source can be a signal applied to either an Input Channel (internal triggering) or on the TRG IN front panel input connector (external triggering).

The trigger can also be managed through software (Please see AgMD2 API documentation for details).

Trigger Impedance & Coupling

The U5310A has a fixed 50 Ω termination impedance with DC coupling.

Trigger Input Bandwidths

The bandwidth depends on the trigger source.

Channel trigger

The -3 dB bandwidth of the comparator of the channel triggers is from DC to 2.6 GHz. For input signals with high frequency components, this means that the signal acquired and displayed doesn’t correspond exactly to the signal seen from the trigger comparator input. Since, the signal seen on the trigger comparator can be attenuated, this should be taken into account when selecting channel triggers and specifying the trigger level.

External trigger

The external trigger inputs have a bandwidth from DC to 2 GHz.

Trigger Level

The trigger level specifies the voltage at which the selected trigger source will produce a valid trigger. All trigger circuits have sensitivity levels that must be exceeded in order for reliable triggering to occur.

The external trigger input and channel triggers have a hysteresis of 5% and 4% of FSR Closed Full Scale Range:- The span of the voltage input of the Digitizer (negative to positive) including the configured offset voltages., respectively (where FSR is the channel Full Scale Range).

On external trigger, the Full Scale Range FSR is ±5 V, therefore the digitizer will trigger on signals with a peak-to-peak amplitude > 0.5 V.

When using the channel triggers, the trigger level must be set within Offset ± FSR .

Edge Trigger Slope

The trigger slope defines which one of the two possible transitions will be used to initiate the trigger when it passes through the specified trigger level. Positive slope indicates that the signal is transitioning from a lower voltage to a higher voltage. Negative slope indicates the signal is transitioning from a higher voltage to a lower voltage.

Trigger Time Interpolator

The digitizer also measures and stores the arrival time of each trigger using the information from the on board Trigger Time Interpolator (TTI Closed Trigger Time Interpolator:- A function that accurately measures the time from the trigger point to the first sample point. The TTI permits accurate positioning of the trigger signal with respect to the internal clock (sampling time).). This information is essential for determining the precise relation between the trigger and the digitized samples of the signal. The TTI resolution determines the resolution of the trigger time stamps.

Please refer to the U5310A datasheet for the relevant specifications.

Trigger precision and resolution

The U5310A trigger time interpolator offers a resolution of 6 to 8 ps (nominal) and a precision of 15 ps RMS (nominal) .

Pre- and Post-Trigger Delay

To increase trigger flexibility, a pre- or post-trigger delay can be applied to the trigger position.

The amount of pre-trigger delay can be adjusted between 0 and 100% of the acquisition time window (i.e. sampling interval x number of samples), whereas the post-trigger delay can be adjusted within the time interval:

from 0 to (232 – 1) * block_size (samples)

where block_size is 16 in non-interleaved mode and 32 in interleaved (combined) mode.

Pre- or post-trigger delays are just different aspects of the same trigger positioning parameter:

  • The condition of 100% pre-trigger indicates that all data points are acquired prior to the trigger, i.e. the trigger point is at the end of the acquired waveform.
  • The condition of 0% pre-trigger (which is identical to a post-trigger of 0%) indicates that all data points are acquired immediately after the trigger, i.e. the trigger point is at the beginning of the acquired waveform.
  • The condition of a non-zero post-trigger delay indicates that the data points are acquired after the trigger occurs, at a time that corresponds to the post-trigger delay, i.e. the trigger point is before the acquired waveform.

The digitizer hardware accepts pre- and post-trigger adjustments in increments of 16 samples. By definition post-trigger settings are a positive number and pre-trigger settings are a negative number.

Thus it is only natural that the software drivers treat pre- and post-trigger delays as a single parameter in seconds that can vary between:

– NbrSamples * SamplingInterval (100% pre-trigger)

and +maxPostTrigSamples * SamplingInterval (max post-trigger).


External Clock and Reference

For applications where the user wants to replace the internal clock of the digitizer and drive the ADC Closed Analog to Digital Converter with an external source, either an External Clock or an External Reference signal can be used. The Clock or Reference signals can be entered into the digitizer by the dedicated REF IN and CLK IN connectors.

External Clock (CLK IN)

The External Clock may be used to vary the sampling rate of the digitizer. If selected for the digitizer, it must be continuously present to operate correctly. The input is AC coupled.

In the initial release, only an external clock with a fixed value is supported.

Parameter | Value
Frequency Range | 5 GHz
Resulting sampling rate without interleaving | 5 GS/s
Resulting sampling rate with interleaving (-INT option) | 10 GS/s
Minimum Amplitude | 0.5 Vp.p into 50 Ω
Maximum Power | 15 dBm
Threshold | 0 V

External Reference (REF IN)

For applications that require greater timing precision and long-term stability than is obtainable from the internal clock, a 100 MHz Reference signal can be used.

The External Reference is nominally at 100 MHz. However, frequencies in a range will be accepted. If your input is not at exactly the specified value, you must remember to compensate for the difference in your application since the digitizer and the driver have no way to know about such deviations.

The input is 50 Ω terminated and AC coupled.

Parameter | Value | Tolerance
Nominal Frequency | 100 MHz |
Signal level | -3 dBm to +3 dBm |
Impedance | 50 Ω |
Coupling | AC |

If synchronization between several digitizers is required, the reference signal should be applied to all of them.


Internal Calibration and Factory Calibration

Internal Calibration

The digitizer includes a high precision voltage source and a 16-bit DAC, used to perform the input voltage and offset calibration.

The software drivers supplied include calibration functions for the timing, gain and offset parameters, which can be executed upon user request. The digitizers are never calibrated in an “automatic” way, (i.e. as a side effect of another operation). This ensures programmers have full control of all calibration operations performed through software in order to maintain proper event synchronization within automated test applications.

For accurate time and voltage measurements it is recommended to perform a calibration once the module has attained a stable operating temperature (usually reached after 20 minutes of digitizer operation after power on). And subsequently a self-calibration should be carried out after any configuration changes are made to the digitizer, before making acquisitions.

A full internal calibration of a digitizer can be time consuming because of the many possible configuration states. Therefore, the self-calibration is performed only for the current configuration state, and is mandatory before making any acquisition. Indeed the MD2 driver prevents an acquisition from being performed unless a self-calibration has first been completed.

Digitizer can usually work with signals present at the external reference and clock inputs (REF IN and CLK IN). However, to ensure the best performance, or if the calibration is found to be unreliable (as shown by a calibration failure status), it is recommended to remove such signals when working with internal clock.

An application program will shut-down devices at exit. As a consequence, an appropriate warm-up period is expected when starting another application program. In this case, it is recommended to wait for couple of minutes for a stable device temperature, before launching the calibration to ensure full performance.

Smart-calibration

The smart calibration implemented in MD2 driver allows to save time by automatically saving and restoring any self-calibration performed since the beginning of the session. When the acquisition parameters are changed, there is no re-calibration of the instrument if a calibration has already been performed with the same acquisition conditions (i.e. the same set of parameters), except for the clock mode parameters.

Indeed, if the clock mode is changed (i.e. External clock frequency, Clock source or Reference mode parameters), a new self-calibration is systematically required for every acquisition condition with the new clock.

For details How to calibrate the instrument?

Factory Calibration

Whilst the Internal Calibration function will provide a good degree of confidence that your instrument is operating within its specifications on a day-to-day basis, Keysight Technologies recommends that each instrument undergoes a Factory Calibration at least annually to ensure that it remains within the specified performances.

Factory Calibration is the process of measuring the actual performance of an instrument-under-test using lab instruments that in turn have significantly better performance than the instrument-under-test. Lab instrument performance must be traceable to the International System (SI) Units via a national metrology institute (NIST, NPL, NRC, PTB, CENAM, INMETRO, BIPM, etc.)

The measured performance is then compared to published datasheet specifications. For each factory calibration, Keysight Technologies tests the performance corresponding to all datasheet specifications, for every installed option. If needed, the instrument is adjusted and re-qualified before returning it to be in line with full specifications.

For more information, or to request for a calibration please see www.keysight.com/find/calibration.


Trigger Output

In idle state, Trigger Out signal is low. When a trigger is accepted a high level pulse occurs.

The pulse duration is typically 192 ns or equal to 960 / external clock frequency if using an external clock.

Figure 9 - Trigger Output Block diagram.

In the default software configuration, the output swing is 1.6 V (±0.8 V) when unloaded and 0.8 V (±0.4 V) when terminated on 50 Ω. The rise and fall times are 2.5 ns typical. The offset can be adjusted, by software control in the range [–2.5 V to +2.5 V] unloaded, or [-1.25 V to +1.25 V] into 50 Ω. The maximum output current capability is ±15 mA. As the output is retro-terminated, it is possible to drive a 50 Ω line un-terminated (HiZ) without loss of performance.

For a TTL compatible signal, set the offset to 1.0 V and the swing at destination will be +0.2 to +1.8 V.

For an ECL compatible signal, terminated on 50 Ω to –1.2 V, set the offset to –1.2 V and the output will be in the range [–0.8 to –1.6 V]).

Alternatively, to reduce the current drawn from the digitizer, the terminations shown here can be used:

Figure 10 - Suggested trigger signal terminations.

The External Trigger Output functionality is implemented in the hardware. No Trigger Out signal occurs for software-generated triggers.


Multi-Purpose Inputs and Outputs

The multi-purpose IO connectors may be used for any of the functions shown in the following table:

IO Connector Functions | Type | Description of signal | Notes
Inputs |  |  |
Disabled | - | IO connector is disabled. |
Outputs |  |  |
Out-100MHzReferenceClockDivBy2 | Clock | The 100 MHz reference clock divided by 2 (50 MHz) | IO 1 only
Out-SamplingClockDivBy32 | Clock | The sampling clock divided by 32 | IO 1 only
Out-AcquisitionActive | Level | Indicates that the acquisition is currently running. | IO 1 & 2 only
Out-TriggerArmed | Level | Trigger is armed. | IO 1 & 2 only
Out-LowLevel | Level | Fixed 'low' level signal for debug purposes. |
Out-HighLevel | Level | Fixed 'high' level signal for debug purposes. |
Out-TriggerAcceptedResync | Pulse | Active when a valid trigger event has occurred. This signal is resynchronized to the sample clock. | IO 1 & 2 only
Out-AveragerAwg | - | Self-Trigger output. | IO 3 only. Requires -AVGoption.

Signal Logic Levels

The multi-purpose IO signals are 3.3 V CMOS compatible (5V Tolerant buffer). The levels shown in the table below should be observed.

Direction | Low level | High level
Input | <0.8 V | >2.0 to 3.45 V
Output | In the range 0 to 0.8 V | In the range 1.6 to 3.3 V
As an Input

The input is high-impedance and will be pulled high if unconnected via an internal weak pull-up (42.2 k pull-up resistor).

Figure 11 - IO-P schematic

As an Output

The high level output will typically give 1.6 V into 50 Ω. As can be seen in the diagram below, the 3.3 V output buffer has a 50 Ω resistor in series. Therefore the available output high level voltage will depend on the load applied. In the example below a 50 Ω termination will result in a nominal high level of 1.6 V. (Vo = (Rload/(50 + Rload)) * 3.3).


Signal Processing Options

This section describes options which may be used when processing the signal.

Averager (AVG)


Averager (AVG)

Introduction

Averaging signals reduces random noise effects, improving the signal-to-noise ratio, as well as increasing resolution and dynamic range.

The main features are:

  • Synchronous, single-channel and dual-channel, real-time sampling and averaging up to 10 GS/s.
  • Averaging from 1 to 16'384 triggers.
  • Effective acquisition length from 1'000 up to 655'360 samples in single channel or up to 327'680 samples per channel in dual-channel.
  • Decimation by 2, 4 and 8.
  • Noise Suppressed Accumulation (NSA).
  • Self-Trigger mode for minimal synchronous (pattern) noise.

Noise Suppressed Accumulation (NSA)

In some applications, such as time-of-flight spectroscopy, the signal is a rare event sitting on top of a noisy baseline and the averaging process reduces the random noise.

As a consequence, to enhance the digitizer ability to detect such signals in the presence of synchronous noise, the averaging firmware allows the user to set a Threshold that must be exceeded for each data value to be entered into the sum. Furthermore, the NoiseBase can be subtracted from each data value above threshold before the accumulation is done (See Figure below). The NoiseBase should always be equal or smaller than the Threshold.

Figure 12 - Signal detection using noise suppressed accumulation

Parameters (Channels2.Item2.Accumulation.NSA interface):

Enabled: Specifies whether the Noise Suppressed Accumulation is active. This attribute affects instrument behavior only when the Acquisition Mode attribute is set to Averager.

NoiseBase: Specifies the noise base value for the Noise Suppressed Accumulation. The noise base is subtracted from data values which are higher than the configured threshold. This parameter is defined per channel in ADC Closed Analog to Digital Converter counts.

Threshold: Specifies the threshold of the Noise Suppressed Accumulation. Each data value must exceed the threshold value to be entered into the sum. This parameter is defined per channel in ADC counts.

Timing sequence

The minimum time between summed events depends on the trigger Rearm Time as specified in the U5310A datasheet.

Figure 13 - Timing sequence in AVG mode

Current solution supports a single record sequence mode.

The number of potential trigger lost between two AVG acquisition sequences depends on several factors:

  • The time to read the previous AVG acquisition sequence, depending on the number of samples to transfer and mainly on the PCIe connection.
  • The time to initiate the next acquisition.

Trigger Modes

Apart from the trigger sources described in the section Trigger (internal and external triggering), this option provides another trigger mode to warranty minimum synchronous (pattern) noise. This trigger source is called Self-Trigger.

In applications where multiple waveforms are accumulated, the synchronicity between ADCs sequence and trigger results in a synchronous noise which often becomes the dominant factor. In theory, setting the external trigger at a specific trigger frequency which ensures that each waveform to be accumulated starts with a different ADC, the user can reduce the synchronous noise. However, in a real application it is not possible to ensure the trigger stability at the optimum condition due to multiple factors, for instance temperature variations.Therefore, the only way to warranty the minimum synchronous noise is using the Self-Trigger mode.

Self Trigger

In this mode, the trigger is generated internally in the digitizer and propagated outside the digitizer through the front panel IO 3. The trigger is controlled to ensure that each waveform to be accumulated starts at a different ADC in the ADC sequence. To use the Self-Trigger mode, the Trigger ActiveSource must be set to "SelfTrigger".

Figure below shows the signal to noise ratio using an external trigger at a frequency multiple of the sampling frequency (worst case) and the Self-Trigger at any frequency (best case).

Figure 14 - Signal to noise ratio vs Number of averagers

Parameters

ActiveSource (Trigger2.ActiveSource interface): Specifies the trigger source. There are three trigger sources: internal, external and self-trigger. If the Self-Trigger mode is selected the Self-Trigger parameters should be set and the IO 3 output should be enabled.

Frequency (Trigger2.Sources2.Item2.SelfTrigger.SquareWave interface): Specifies the frequency of the Self-Trigger square wave signal. The units are Hertz.

DutyCycle (Trigger2.Sources2.Item2.SelfTrigger.SquareWave interface): Configures the duty cycle of the Self-Trigger square wave signal. Units are percentage of the period.

Slope (Trigger2.Sources2.Item2.SelfTrigger.SquareWave interface): Specifies whether a rising or a falling edge of the generated waveform triggers the digitizer.

Out-AveragerAwg (ControlIOs interface): Self-Trigger signal is propagated through the IO 3.

Post Trigger Delay

The post-trigger delay is a multiple of 6.4 ns (coded in 24 bits) and can be adjusted within the time interval from 0 to (224) x 6.4 x 10-9 seconds.

Multi-Purpose Inputs and Outputs (IO 1, 2)

The multi-purpose inputs and outputs (IO 1, 2) in the front panel may be used to control the accumulation or read the digitizer status:

Parameters (ControlIOs interface)

In-AccumulationEnable: digitizer input (IO 1). This signal controls the averaging sequence checking its value only at the averager start. If the accumulation enable is '1' at the start, the averager will perform the average independently of this input value. By the contrary, if the accumulation enable is '0' at the start, the digitizer will wait until the accumulation enable rises to start the averaging at that moment (no need for a new start).

Out-AccumulationActive: digitizer output (IO 2). This signal informs that the digitizer is busy acquiring or accumulating the last averages.

Out-AcquisitionActive: digitizer output (IO 1 or IO 2). This signal informs that the digitizer is busy acquiring.

Other AVG Parameters

Finally, there are two specific parameters commonly used in the averager:

NumberOfAverages: number of waveforms to average in the record.

DataInversionEnabled: the data acquired may be inverted if desired.

Mode: select the averager mode (AgMD2AcquisitionModeAverager in IVI-COM or AGMD2_VAL_ACQUISITION_MODE_AVERAGER in IVI-C)

AVG Configuration

The interfaces/methods/properties (functions/attributes) listed below are provided by the Keysight MD2 driver. Detailed help on these interfaces may be found in the AgMD2 IVI Driver Reference Manual.

IVI-COM

Interface | Method / Property name | Description
IAgMD2TriggerSource2SelfTrigger | AbortGeneration | Stops the generation of the self-trigger signal previously initiated.
 | InitiateGeneration | Starts the generation of the self-trigger signal.
 | Mode | Defines the self-trigger signal generation mode.
IAgMD2TriggerSource2SelfTriggerSquareWave | Configure | Configures the square wave signal properties of the self-trigger generator. Calling this function will automatically set the self-trigger mode to Square Wave.
 | DutyCycle | Configures the duty cycle of the self trigger square wave signal. Behavior depends on the configuration of the Slope property (e.g. if Slope is set to positive DutyCycle defines the percentage that the square wave is in the high state). Units are percentage of the period.
 | Frequency | Specifies the frequency of the self-trigger square wave signal. The units are Hertz.
 | Slope | Specifies whether a rising or a falling edge of the generated waveform triggers the digitizer.
IAgMD2TriggerSource2SelfTriggerCustomWave | LoadConfigurationFile | Loads the configuration for the self-trigger generator from a specified configuration file. Calling this function will automatically set the self-trigger mode to Custom Wave.
IAgMD2Acquisition | Mode | The acquisition mode.
IAgMD2Acquisition2 | NumberOfAverages | Specifies the number of waveforms to average in the record. This attribute affects instrument behavior only when the Acquisition Mode attribute is set to Averager or PeakDetection.
IAgMD2Channel2 | DataInversionEnabled | Specifies whether the data acquired is inverted.
IAgMD2Channel2AccumulationNSA | Configure | Configures the Noise Suppressed Accumulation properties.
 | Enabled | Specifies whether the Noise Suppressed Accumulation is active. This attribute affects instrument behavior only when the Acquisition Mode attribute is set to Averager.
 | NoiseBase | Specifies the noise base value for the Noise Suppressed Accumulation. The noise base is subtracted from data values which are higher than the configured threshold. The units are ADC counts.
 | Threshold | Specifies the threshold of the Noise Suppressed Accumulation. Each data value must exceed the threshold value to be entered into the sum. The units are ADC counts.
IAgMD2ChannelMeasurement2 | FetchAccumulatedWaveformInt32 | This function returns the accumulated waveform which the digitizer has acquired for the specified channel. This waveform is from a previously initiated accumulated acquisition in Averager or Peak Detection mode. Returned waveform data units are raw accumulated ADC values which may be converted to Volts by the formula: V = ScaleFactor * data + ScaleOffset.
 | FetchAccumulatedWaveformReal64 | This function returns the averaged waveform which the digitizer has acquired for the specified channel. This waveform is from a previously initiated accumulated acquisition in Averager or Peak Detection mode. Returned waveform data units are Volts.

IVI-C

Functions

Function | Description
AgMD2_SelfTriggerAbortGeneration | Stops the generation of the self-trigger signal previously initiated.
AgMD2_SelfTriggerInitiateGeneration | Starts the generation of the self-trigger signal.
AgMD2_SelfTriggerSquareWaveConfigure | Configures the square wave signal properties of the self-trigger generator. Calling this function will automatically set the self-trigger mode to Square Wave.
AgMD2_SelfTriggerCustomWaveLoadConfigurationFile | Loads the configuration for the self-trigger generator from a specified configuration file. Calling this function will automatically set the self-trigger mode to Custom Wave.
AgMD2_NSAConfigure | Configures the Noise Suppressed Accumulation properties.

Attributes

Attribute | Description
AGMD2_ATTR_SELF_TRIGGER_MODE | Defines the self-trigger signal generation mode.
AGMD2_ATTR_SELF_TRIGGER_SQUARE_WAVE_DUTY_CYCLE | Configures the duty cycle of the self trigger square wave signal. Behavior depends on the configuration of the Slope property (e.g. if Slope is set to positive DutyCycle defines the percentage that the square wave is in the high state). Units are percentage of the period.
AGMD2_ATTR_SELF_TRIGGER_SQUARE_WAVE_FREQUENCY | Specifies the frequency of the self-trigger square wave signal. The units are Hertz.
AGMD2_ATTR_SELF_TRIGGER_SQUARE_WAVE_SLOPE | Specifies whether a rising or a falling edge of the generated waveform triggers the digitizer.
AGMD2_ATTR_ACQUISITION_MODE | The acquisition mode.
AGMD2_ATTR_ACQUISITION_NUMBER_OF_AVERAGES | Specifies the number of waveforms to average in the record. This attribute affects instrument behavior only when the Acquisition Mode attribute is set to Averager or PeakDetection.
AGMD2_ATTR_CHANNEL_DATA_INVERSION_ENABLED | Specifies whether the data acquired is inverted.
AGMD2_ATTR_NSA_ENABLED | Specifies whether the Noise Suppressed Accumulation is active. This attribute affects instrument behavior only when the Acquisition Mode attribute is set to Averager.
AGMD2_ATTR_NSA_NOISE_BASE | Specifies the noise base value for the Noise Suppressed Accumulation. The noise base is subtracted from data values which are higher than the configured threshold. The units are ADC counts.
AGMD2_ATTR_NSA_THRESHOLD | Specifies the threshold of the Noise Suppressed Accumulation. Each data value must exceed the threshold value to be entered into the sum. The units are ADC counts.


Electrical & Environmental Specifications

For full specifications, please refer to the product data sheet which may be found on the CD which came with your product, or from the Keysight Technologies website: www.keysight.com/find/U5310A


Programming Information

This section provides general programming advice and specific information regarding the use of the Keysight drivers.

The AgMD2 IVI driver provides access to the functionality of AgMD2 digitizers through a COM server or ANSI C API which also complies with the IVI specifications.

The AgMD2 API documentation can be found MD2 IVI Driver Help in or from Start > All programs > Keysight MD2 Digitizer AgMD2 IVI Driver Help

Program examples can be found in C:\Program Files Closed (Or your installation path) \IVI Foundation\IVI\Drivers\AgMD2\Examples

IVI-COM Driver development environments

The AgMD2 IVI-COM driver can be used in the following development environments:

  • Visual C#
  • Visual C++
  • Visual Basic.NET
  • Keysight VEE Pro
  • LabVIEW
  • MATLAB.

The section AgMD2 IVI-COM Driver > Programming with the IVI-COM Driver in Various ADEs of the AgMD2 IVI documentation describes how to use the IVI-COM driver from the different development environments.

Additionally AgMD2 IVI-COM sample codes can be found in the folders (depending on your installation path):

  • C:\Program Files Closed (Or your installation path) \IVI Foundation\IVI\Drivers\AgMD2\Examples\CppIviCom
  • C:\Program Files Closed (Or your installation path) \IVI Foundation\IVI\Drivers\AgMD2\Examples\CSharp
  • C:\Program Files Closed (Or your installation path) \IVI Foundation\IVI\Drivers\AgMD2\Examples\MATLAB\IVI-COM
  • C:\Program Files Closed (Or your installation path) \IVI Foundation\IVI\Drivers\AgMD2\Examples\VisualBasic

IVI-C Driver development environments

The AgMD2 IVI-C driver can be used in the following development environments:

  • Visual C++
  • LabWindow/CVI
  • LabVIEW
  • MATLAB.

The section AgMD2 IVI-C Driver > Programming with the IVI-C Driver in Various ADEs of the AgMD2 IVI documentation describes how to use the IVI-C driver from the different development environments.

Additionally AgMD2 IVI-C sample codes can be found in the folder (depending on your installation path):

  • C:\Program Files Closed (Or your installation path) \IVI Foundation\IVI\Drivers\AgMD2\Examples\CppIviC
  • C:\Program Files Closed (Or your installation path) \IVI Foundation\IVI\Drivers\AgMD2\Examples\MATLAB\IVI-COM

Section Content

Warning when migrating from MD2 1.x to MD2 2.x

Initial Configuration

How To ...

ApplySetup

MATLAB support and known limitations


Migrate from MD2 1.x to MD2 2.x

You are here: U5310A User Manual > Programming Information > Warning when migrating from MD2 1.x to MD2 2.x

Warning when migrating from MD2 1.x to MD2 2.x

Starting from MD2 2.0, the IVI-C driver is not backward compatible.

With AgMD2 2.0, the backward compatibility is broken for the functions:

AgMD2_FetchWaveformInt8

AgMD2_FetchMultiRecordWaveformInt8

AgMD2_ReadWaveformInt8

These function signatures have changed in line with IVI standard evolution: WaveformArray parameter type has been updated from ViChar[ ] to ViInt8[ ].

However AgMD2 1.x and AgMD2 2.0 binary files are compatible: user binaries compiled with AgMD2 1.x will work with 2.x driver, for both IVI-C and IVI-COM interfaces.

Existing source code has to be updated to allow the compilation with AgMD2 2.x.


Initial Configuration

At initialization, the driver uses the pre-defined defaults values. The following table details the initial configuration of the digitizer.

Property | Default value | Comment
Channeli | Enable |
Input filter | For -F25 Bypass = Yes | By default, the bandwidth limiter is disable.
Vertical range | 1 (Volts) |
Vertical offset | 0 (Volts) |
Vertical coupling | DC |
Trigger source | Internal1 |
Trigger delay | 0 (ns) |
Trigger type | Edge |
Trigger coupling | DC |
Trigger level | 0 (Volts) |
Trigger slope | Positive |
Interleave | Disable |
Mode | Normal (DGT) |
Sampling rate | 5 GS/s | Default is the higher value supported by the module without interleaving
Sample clock | Internal |
Sample clock external frequency | 5 GS/s | External Clock and Reference
Sample clock external divider | 1 | Fixed (Sample clock external frequency / Sampling rate)
Reference oscillator | Internal |
Reference oscillator frequency | 100 MHz | Fixed
Record size | 1024 |
Number of records to acquire | 1 |
Number of averages | 1 | for AVG mode only


How To ...

Discover the PXI Instrument

Calibrate the instrument

Access repeated capabilities

Generate a software trigger

Perform interleaved acquisition

Bypass the filter

Binary decimation (depending on firmware)

Perform partial readout

Load a new firmware

Migrate from Acqiris or MD1 to MD2


Discover the PXI Instrumen

You are here: U5310A User Manual > Programming Information > How To ... > Discover the PXI Instrument

How to discover the PXI Instrument?

The C/C++ code below can be used to discover the PXI instruments on user system and get their VISA addresses.

#include <stdio.h>

#include <visa.h>

int main()

{

ViSession rm = VI_NULL;

ViSession vi = VI_NULL;

viOpenDefaultRM( &rm );

ViChar search[] = "PXI?*::INSTR";

ViFindList find = VI_NULL;

ViUInt32 count = 0;

ViChar rsrc[256];

ViChar modelName[256];

ViStatus status = viFindRsrc( rm, search, &find, &count, rsrc );

if ( status==VI_SUCCESS && count>0 )

{

do

{

viOpen(rm, rsrc, 0, 0, &vi);

viGetAttribute(vi, VI_ATTR_MODEL_NAME, modelName);

viClose(vi);

printf( "Found: \"%s\" - Model Name: %s\n", rsrc, modelName);

status = viFindNext( find, rsrc );

} while( status==VI_SUCCESS );

viClose( find );

}

viClose( rm );

}


How to calibrate the instrument?

Calibration principle

The card is initialized without calibration.

A calibration is mandatory before making any acquisition to guarantee measurement accuracy. MD2 driver prevents an acquisition from being performed unless a self-calibration has first been completed.

Since a full internal calibration of a digitizer can be time consuming because of the many possible configuration states, the self-calibration is performed only for the current configuration state. A new self-calibration is required after every change of configuration of the instrument.

Internal Calibration and Factory Calibration

Running fast calibration

The function SelfCalibrate should be used to perform a fast calibration.

As explained above, a calibration is required after every acquisition parameter modification (e. g. full scale range, filter, sample rate, ...). The Calibration.IsRequired IVI-COM property or the AGMD2_ATTR_CALIBRATION_IS_REQUIRED IVI-C attribute can be used to check if a new self calibration is required .

MD2 Smart-calibration

The smart calibration implemented in MD2 driver allows to save time by automatically saving and restoring any self-calibration performed since the beginning of the session. When the acquisition parameters are changed, there is no re-calibration of the instrument if a calibration has already been performed with the same acquisition conditions (i.e. the same set of parameters), except for the clock mode parameters.

Indeed, if the clock mode is changed (i.e. External clock frequency, Clock source or Reference mode parameters), a new self-calibration is systematically required for every acquisition condition with the new clock.

Parameter change requiring a new self calibration

The table below lists the parameters that require a new self calibration of the instrument when changed.

 | Parameter | Calibration required
Acquisition | Sampling rate | Only the 1st time, for an identical set of parameter values.
Channel1 parameters | Vertical range
 | Input filter Bypass (Yes/No)
 | Interleave (Enable or not)
Channel(i) parameters | Vertical range
 | Input filter Bypass (Yes/No)
 | Interleave (Enable or not)
Trigger | Trigger source | Only the 1st time
Clock mode | External clock frequency | Each time this parameter changes
 | Clock source | Each time this parameter changes
 | Reference mode (External or Internal Reference) | Each time this parameter changes

The channel parameters are calibrated independently per channel.

Saving and restoring calibration setup

It is also possible to save calibration parameters and restore them during future sessions.

The function Calibration SaveToFile allows to save in a single file the calibration values from all calibrations done in the current user session (IVI-COM method: IAgMD2Calibration.SaveToFile, IVI-C function: AgMD2_CalibrationSaveToFile).

In the next session, after performing a single calibration, user can restore all the saved calibration values using Calibration Load From File function (IVI-COM method: IAgMD2Calibration.LoadFromFile, IVI-C function: AgMD2_CalibrationLoadFromFile).

To guarantee acquisition accuracy, at least one calibration with the chosen clock mode and trigger source (group B and C) has to be performed when starting a new session.Thus the Save and Load functions, only apply to Acquisition sampling rate and Channel parameters (group A). Only these parameters can be re-used between sessions.

Save and restore procedure

User can generate a set of calibration values and store the calibrated configurations:

  1. Open a session to the module and put it into operating conditions
  2. Calibrate the module in all desired configurations
  3. Call Calibration SaveToFile to store the calibration state of all calibrated configurations
  4. Close the module session.

Then the previously saved calibration states could be re-used:

  • Open a session to the module
  • Configure required the clocking mode and trigger source (internal sample clock / external sample clock / external reference oscillator)
  • Call SelfCalibrate once for each trigger source user intends to use
  • Call Calibration LoadFromFile to restore the previously saved calibration state
  • The calibration state loaded from the file which best matches the current configuration and temperature will be used for acquisitions

If the clock mode (Reference Oscillator Source or Sample Clock Source) is changed, steps 3 and 4 have to be repeated.


How to access repeated capabilities ?

For U5310A, the AgMD2 driver supports the following repeated capabilities with pre-defined values detailed in following table.

Repeated capability | Available instance name
Channel | "Channel1", "Channel2"
TriggerSource | "Internali", with i = [1-2] "External1", "Software", "Immediate", "SelfTrigger" (for AVG mode)
ArmSource | Not supported
LogicDevice | Not supported
PrivateFirmware | Not accessible
PrivateStore | Not accessible
ControlIO1 | "ControlIO1", "ControlIO2", "ControlIO3"
DelayControl | Not supported
LogicDeviceIFDL (Inter FPGA Closed Field Programmable Gate Array Data Link) | Not supported
LogicDeviceMemoryBank | Not supported
MonitoringValue | These parameters are for information only or can be used for debugging purpose. The are accessible through the MD2 SFP Closed Soft Front Panel or the command below. For details, please refer to MD2 IVI Driver Help.
Stream | Not supported

1For details, please refer to Multi-Purpose Inputs and Outputs.

The number of instances and their names however can be queried from the driver:

  • Using the AgMD2 IVI-COM driver:

    Collection interfaces have a Count property, and a Name[index] array.

  • Using the AgMD2 IVI-C driver:

    For each repeated capability Xxx, there is a AGMD2_ATTR_XXX_COUNT attribute and a AgMD2_GetXxxName function (e.g. AGMD2_ATTR_CHANNEL_COUNT attribute and AgMD2_GetChannelName function).


Migrate from Acqiris or MD1 to MD2

You are here: U5310A User Manual > Programming Information > How To ... > Generate a software trigger

How to generate a software trigger?

The function AgMD2_SendSoftwareTrigger sends a single software trigger and needs to be called as many times as they are incomplete records.


Perform interleaved acquisition

You are here: U5310A User Manual > Programming Information > How To ... > Perform interleaved acquisition

How to perform time-interleaving acquisitions?

It is possible to combine two channels and to perform an acquisition at higher sampling rate.

The following example give the function calls used to:

  • combine the two channels,
  • use channel 1
  • and set the sampling rate to 10 GS/s

Channels time-interleaving (IVI-COM)

IAgMD2ChannelPtr spCh1 = spDriver->Channels->Item[L"Channel1"];

spCh1->TimeInterleavedChannelList = "Channel2";

double sampleRate = 10e9;

spDriver->Acquisition->SampleRate = sampleRate;

Channels time-interleaving (IVI-C)

AgMD2_SetAttributeViString(session, "Channel1", AGMD2_ATTR_TIME_INTERLEAVED_CHANNEL_LIST, "Channel2");

AgMD2_SetAttributeViReal64(session, "", AGMD2_ATTR_SAMPLE_RATE, 10e9);


How to enable or bypass the filter?

The following commands allow to bypass the filter.

  • Using the AgMD2 IVI-C driver:

AgMD2_SetAttributeViBoolean(session, "Channel1", AGMD2_ATTR_INPUT_FILTER_BYPASS, VI_TRUE);
  • Using the AgMD2 IVI-COM driver:

IAgMD2ChannelPtr spCh1 = spDriver->Channels->Item[L"Channel1"];

spCh1->Filter->Bypass = true;

The following commands allow to enable the filter.

  • Using the AgMD2 IVI-C driver:

AgMD2_SetAttributeViBoolean(session, "Channel1", AGMD2_ATTR_INPUT_FILTER_BYPASS, VI_FALSE);
  • Using the AgMD2 IVI-COM driver:

IAgMD2ChannelPtr spCh1 = spDriver->Channels->Item[L"Channel1"];

spCh1->Filter->Bypass = false;


How to do binary decimation ? (depending on firmware)

The binary decimation is not supported for all combinations of firmware, channel configuration and sampling rate.

It is supported only with the digitizer (-DGT) or TSR (-TSR) mode. It is not supported in Averager (-AVG) or Peak Detection (-PKD) mode.

The available decimation factors depend on the channel configuration (-CHx) and sampling rate (-SRx) options of your digitizer.

Please refer to the Data Acquisition Section for more information.

  • Using the AgMD2 IVI-COM driver:

To use the binary decimation and set the sample rate to a lower value use the SampleRate property.

sampleRate = 200e6;

spDriver->Acquisition2->SampleRate = sampleRate;

  • Using the AgMD2 IVI-C driver:

To use the binary decimation and set the sample rate to a lower value use the AGMD2_ATTR_SAMPLE_RATE attribute.

sampleRate = 200e6;

status=AgMD2_SetAttributeViReal64(session,””, AGMD2_ATTR_SAMPLE_RATE,sampleRate);


Perform partial readout

You are here: U5310A User Manual > Programming Information > How To ... > Perform partial readout

How to perform partial readout?

If the acquisition uses a single record with large record size, the digitizer memory can be read in two or more blocks. It is possible to read the data partially using several calls to AgMD2_FetchMultiRecordWaveformXXX (IVI-C)or MultiRecordMeasurement.FetchMultiRecordWaveformXXX(IVI-COM) function, defining the first record, the number of records, the first point and the number of points the user wants to read at each call of the function.

Example using AgMD2 IVI-C

Reading Int16 data in two blocks of points/2 length each (with NUM_RECORDS =1)

status = AgMD2_QueryMinWaveformMemory(session, 16, NUM_RECORDS, 0, points/2, &arraySize);

dataArray = (ViInt16*)malloc((size_t)arraySize * sizeof(ViInt16));

// Perform the acquisition.

printf("Performing acquisition\n");

status = AgMD2_InitiateAcquisition(session);

status = AgMD2_WaitForAcquisitionComplete(session, timeoutInMs);

if (status)

{

}

// Fetch the acquired data in array.

status = AgMD2_FetchMultiRecordWaveformInt16(session, "Channel1", 0, NUM_RECORDS, 0, points/2, arraySize, dataArray, &waveformArrayActualSize, &actualRecords, actualPoints, firstValidPoint, initialXOffset, initialXTimeSeconds, initialXTimeFraction, &xIncrement,&scaleFactor,&scaleOffset);

if (status)

{

}

status = AgMD2_FetchMultiRecordWaveformInt16(session, "Channel1", 0, NUM_RECORDS, points/2, points/2, arraySize, dataArray, &waveformArrayActualSize, &actualRecords, actualPoints, firstValidPoint, initialXOffset, initialXTimeSeconds, initialXTimeFraction, &xIncrement,&scaleFactor,&scaleOffset);

if (status)

{

}

Example using AgMD2 IVI-COM (C-sharp)

Reading Int32 data in two blocks (with NUM_RECORDS =1)

long firstRecord = 0;

long offsetWithinRecord = 0;

long actualRecords = 0;

long[] actualPoints = null;

long[] firstValidPoint = null;

double[] initialXOffset = null;

double[] initialXTimeSeconds = null;

double[] initialXTimeFraction = null;

double xIncrement = 0;

double scaleFactor = 0;

double scaleOffset = 0;

long numRecordsToRead = 1;

long numPointToRead = agDrvr.Acquisition.RecordSize/2;

long arrayElements = agDrvr.Acquisition3.QueryMinWaveformMemory(32, numRecordsToRead, 0, agDrvr.Acquisition.RecordSize);

Int32[] waveformArray1 = new Int32[arrayElements];

//To first the first numPointToRead data:

agDrvr.Channels.get_Item(channel).MultiRecordMeasurement.FetchMultiRecordWaveformInt32(

firstRecord,

numRecordsToRead,

offsetWithinRecord,

numPointToRead,

ref waveformArray1,

ref actualRecords,

ref actualPoints,

ref firstValidPoint,

ref initialXOffset,

ref initialXTimeSeconds,

ref initialXTimeFraction,

ref xIncrement,

ref scaleFactor,

ref scaleOffset);

Int32[] waveformArray2 = new Int32[arrayElements];

//To first the last numPointToRead data:

agDrvr.Channels.get_Item(channel).MultiRecordMeasurement.FetchMultiRecordWaveformInt32(

firstRecord,

numRecordsToRead,

offsetWithinRecord+numPointToRead,

numPointToRead,

ref waveformArray2,

ref actualRecords,

ref actualPoints,

ref firstValidPoint,

ref initialXOffset,

ref initialXTimeSeconds,

ref initialXTimeFraction,

ref xIncrement,

ref scaleFactor,

ref scaleOffset);


How to load a new firmware?

The on-board FPGAs (field-programmable gate arrays) contain processor logic needed to efficiently execute several crucial functions. They will be automatically programmed at startup before calibration.


Migrate from Acqiris or MD1 to MD2

You are here: U5310A User Manual > Programming Information > How To ... > Migrate from Acqiris or MD1 to MD2

How to migrate from Acqiris or MD1 to MD2?

Migration from MD1 to MD2

The procedure is described in AgMD2 Software migration note available from Windows Start Menu > Keysight MD2 digitizer > AgMD2 Software Migration.

Migration from Acqiris to MD2

First, the environment settings and libraries should be redefined. Details can be found in following documentations:

AgMD2 IVI-COM Driver > Programming with the IVI-COM Driver in Various ADEs

AgMD2 IVI-C Driver > Programming with the IVI-C Driver in Various ADEs

Secondly, user code should be updated: For each "Acqrs_" and "AcqrsD1_" functions, user need to find the equivalent in the AgMD2_ functions. Note that in some cases it might be required to use a group of functions to emulate the previous one.

For a cross-reference table between Acqiris API and AgMD2 function or for any question, please contact Keysight technical support for assistance at acqiris_support@keysight.com.


ApplySetup

The MD2 driver implements the following consistent behavior: No configuration change is applied immediately to the instrument hardware. Specifically, this means that setting any property/attribute only changes the 'setup' in the driver, and an explicit call to ApplySetup is required to implement the change in the instrument hardware.

There are some exceptions for 'actions': being methods/functions that perform an action which e.g. modifies also the instrument's state.

The following methods WILL perform an implicit ApplySetup before the actual action:

Actions with implicit ApplySetup

Method name | Description
SelfTest | To insure the instrument is actually in the desired state before doing the self test.
SelfCalibrate | To insure the instrument is actually in the desired state before self-calibrating.
Initiate | To apply the configured setup to the instrument hardware before starting the measurement.
Read | All Read methods start by performing an Initiate followed by Wait and then Fetch.
Reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends.
ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.


MATLAB support and known limitations

The following table details the supported platforms and known issues for MATLAB drivers:

MATLAB Version | Windows 32-bit |  | Windows 64-bit
 | IVI-C | IVI-COM | IVI-C | IVI-COM
MATLAB R2012b (32 and 64-bit) and previous | Not supported
MATLAB R2013a to R2014b (32-bit) | Ok See notes: 2, 3. | Ok See note 1. | Ok See notes: 2, 3. | Ok See note 1.
MATLAB R2013a to R2014b (64-bit) |
MATLAB R2015a or b (32-bit) | Not supported | Not supported |  | Not supported
MATLAB R2015a or b (64-bit) |

  1. IVI-COM: The IviDigitizer class FetchMultiRecordWaveform functions do not work. Please use the MD2 driver specific equivalent functions instead.
  2. IVI-C: The command 'mex -setup' has to be run each time when switching from a version of MATLAB to another to avoid issues.
  3. IVI-C: When running the 'mex -setup' command, another supported compiler has to be selected than the one provided by MathWorks (Lcc). Otherwise Int64 attributes will not be supported.

    Mathworks doesn’t plan to support 32-bit version of MATLAB starting from 2016a.


Utilities

This section describes supplied programs which may be used to configure various aspects of your instruments.

Firmware Upgrade Utility

Option Upgrade Utility


Firmware Update Utility (AgMD2UpdateFirmware)

The AgMD2UpdateFirmware programming utility (AgMD2UpdateFirmware.exe) is used to load firmware to your Keysight instrument.

AgMD2UpdateFirmware General Information

The command line tool used is AgMD2UpdateFirmware.exe

Syntax:

AgMD2UpdateFirmware.exe <ModuleResourceName> <DestinationStore> <filename>

The ModuleResourceName value is the VISA resource string.

The DestinationStore value should be ConfigFlashCtrlFpga.

All of the listed parameters are mandatory.

Filename conventions

Files with the ".mcs" extension contain instrument operating firmware generated by Keysight, but may be used on any instrument of the appropriate model type.

If one or more spaces appear in the filename or path, the double quotes are required on the filename string as shown in the examples below.

It is not possible for the utility to check that the file is suitable for the FPGA Closed Field Programmable Gate Array / CPLD of the specified device, so please use this mode carefully. Programming a device with the incorrect firmware file may render it unusable.
However, as long as the device has not yet been re-booted (power cycled) it will be possible to re-write the correct file. Conversely, if the device has been incorrectly programmed and subsequently re-booted, it will be necessary to return it to an Keysight Service Center for recovery.

Instructions:

Open a Command Prompt Window (Start > Programs > Accessories > Command Prompt) and run the following commands:.

cd C:\Program Files Closed (Or your installation path)\Keysight\MD2\Bin

AgMD2UpdateFirmware.exe PXIx::0::0::INSTR ConfigFlashCtrlFpga "C:\Program Files\IVI Foundation\IVI\Drivers\AgMD2\Firmware\U5310A CTRL_DPUSX3.mcs"

The control file depends on the model type (for example U5310A CTRL_DPUSX3.mcs)

PXIx::0::0::INSTR is the VISA resource string, it must match the resource string as shown in the Keysight Connection Expert. You can find the VISA resource string in the Keysight Connection Expert by clicking on the U5310A and then on the Instrument Properties tab (see U5310A Startup Guide > "Step 5: Verify Operation of the U5310A Module" for more information).

"Firmware update successful" is displayed on the screen, once the programming is completed,

Shutdown and restart your computer to take into account the modifications.


Customer Options Upgrade Utility

The Customer Options Upgrade utility (KtMD2LoadEeprom) allows to upgrade the digitizer with new customer options, loading the customer option EEPROM file.

The command line tool used is KtMD2LoadEeprom.exe

Syntax:

KtMD2LoadEeprom.exe <ModuleResourceName> <SourceFile>

The ModuleResourceName value is the VISA resource string.

If one or more spaces appear in the filename or path, the double quotes are required on the filename string.


FAQs

Q. What is Coherent Sampling

A. Coherent Sampling refers to the relationship between the input frequency, sampling frequency, number of cycles in the sampled set and the number of samples. With coherent sampling one is assured that the signal power in an FFT is contained within one FFT bin (assuming a single input tone).

The condition for coherent sampling is given by:

For example if we have Msamples = 211, and fs = 100e6, and we expect and input frequency close to fs/2, let's say fin = 44 MHz, then Ncycles = 901.12 which is close to an integer. We could therefore round down to Ncycles = 901 and we would get fin = 43.994140625 Mhz, which is an input frequency that satisfies coherent sampling.

The integer number should be chosen carefully. We have three possible types of integers, even, odd, and prime. Even is not a good idea since we would hit the same code every Msamples, where M can be much less than N. Odd is a better idea since it takes longer to hit the same code. According to some sources a prime number of cycles is the best (with the exception of the prime 2) because it takes a long time before the same code repeats.

——————————————————————

Q. How to manage the internal temperature?

A. The operating temperature of the U5310A as specified in the U5310A datasheet is the PC internal ambient temperature at intake of the digitizer's fan.

The effective temperature limit is fixed by the maximum internal DPU Closed Digital Processing Unit temperature which should stay below 85°C to guarantee FPGA Closed Field Programmable Gate Array proper operating.

This DPU FPGA core Temperature (or junction temperature Tj) can be monitored from the MD2 SFP Closed Soft Front Panel or using the function BoardTemperature (IVI-COM) / AgMD2_QueryBoardTemperature (IVI-C).

The digitizer's fan speed is controlled with the internal temperature, it maintains the FPGA core temperature below 85°C.

Note that the temperatures in channel ADCs (given by ChannelTemperature (IVI-COM) / AgMD2_ChannelTemperature (IVI-C)) can reach 100°C in standard operating mode.

——————————————————————

——————————————————————


Trigger

Normally the trigger settings applied to the digitizer are used to determine the time at which the device will stop acquiring data. The various trigger settings are outlined below.

Trigger Source

Trigger Impedance & Coupling

The U5310A has a fixed 50 Ω termination impedance with DC coupling.

Trigger Input Bandwidths

The bandwidth of the channel triggers is .

The external trigger inputs have a bandwidth from DC to 2 GHz.

Trigger Level

The trigger level specifies the voltage at which the selected trigger source will produce a valid trigger. All trigger circuits have sensitivity levels that must be exceeded in order for reliable triggering to occur.

Edge Trigger Slope

The trigger slope defines which one of the two possible transitions will be used to initiate the trigger when it passes through the specified trigger level. Positive slope indicates that the signal is transitioning from a lower voltage to a higher voltage. Negative slope indicates the signal is transitioning from a higher voltage to a lower voltage.

Trigger Time Interpolator

The digitizer also measures and stores the arrival time of each trigger using the information from the on board Trigger Time Interpolator (TTI Closed Trigger Time Interpolator:- A function that accurately measures the time from the trigger point to the first sample point. The TTI permits accurate positioning of the trigger signal with respect to the internal clock (sampling time).). This information is essential for determining the precise relation between the trigger and the digitized samples of the signal. The TTI resolution determines the resolution of the trigger time stamps.

Pre- and Post-Trigger Delay

To increase trigger flexibility a pre- or post-trigger delay can be applied to the trigger position.

The amount of pre-trigger delay can be adjusted between 0 and 100% of the acquisition time window (i.e. sampling interval x number of samples), whereas the post-trigger delay can be adjusted within the time interval from 0 to (232 – 1) * block_size (samples), where

Pre- or post-trigger delays are just different aspects of the same trigger positioning parameter:

  • The condition of 100% pre-trigger indicates that all data points are acquired prior to the trigger, i.e. the trigger point is at the end of the acquired waveform.
  • The condition of 0% pre-trigger (which is identical to a post-trigger of 0%) indicates that all data points are acquired immediately after the trigger, i.e. the trigger point is at the beginning of the acquired waveform.
  • The condition of a non-zero post-trigger delay indicates that the data points are acquired after the trigger occurs, at a time that corresponds to the post-trigger delay, i.e. the trigger point is before the acquired waveform.

The digitizer hardware accepts pre- and post-trigger adjustments in increments of 16 samples. By definition post-trigger settings are a positive number and pre-trigger settings are a negative number.

Thus it is only natural that the software drivers treat pre- and post-trigger delays as a single parameter in seconds that can vary between

–NbrSamples * SamplingInterval (100% pre-trigger)

and +maxPostTrigSamples * SamplingInterval (max post-trigger).